Configuring BIDI / Arabic / Hebrew Reports in 11g R2 – REP-56048: Engine rwEng-0 crashed

Recently I have been getting MANY frustrated inquiries regarding how to properly configure Hebrew / Arabic / BIDI reports for Forms/Reports 11g R2.

In general I get 2 types of errors from customers when running with Hebrew reports:

Firstly,  instead of seeing Hebrew / Arabic characters when a report is run they see various symbols @#!$%^&*.  When this happens most people decide to replace the uifont.ali file that comes with Reports 11g R2 with the uifont.ali file that supported BIDI characters from 10g systems. Once they do this replacement they get the second error which is error message REP-56048: Engine rwEng-0 crashed and the report server crashes when they run a Report containing Hebrew characters.

After see many SR’s on the subject I decided I would write a handy whitepaper for you all on how to configure Hebrew reports on 11g R2 with ease.

The guide to Hebrew reports for Windows can be downloaded here

I know developers have been getting similar errors running Arabic reports so this may help them as well. If it works for Arabic please let me know in the comments section. Thanks

About these ads

One comment on “Configuring BIDI / Arabic / Hebrew Reports in 11g R2 – REP-56048: Engine rwEng-0 crashed

  1. Hi,
    Thanks for your detailed document.
    I’ve been surfing the internet for the past four and finally got my answers thru your posting.
    Yes, It’s working for Arabic..
    Thanks Again.
    Regards
    Rifai Rahman M

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s